GoodCoder666的个人博客

AtCoder Beginner Contest 196 A~E 题解

2021-04-01 · 10 min read
C++ 算法竞赛

A - Difference Max

题目大意

给定四个整数a,b,ca,b,cdd
我们要选择两个整数xxyyaxba\le x\le bcydc\le y\le d)。输出最大的xyx-y

100ab100-100\le a\le b\le 100
100cd100-100\le c\le d\le 100

输入格式

a  ba~~b
c  dc~~d

输出格式

输出最大的xyx-y

样例

aa bb cc dd 输出
00 1010 00 1010 1010
100-100 100-100 100100 100100 200200
100-100 100100 100-100 100100 200200

分析

如果要xyx-y最大,那么xx要尽可能大、yy要尽可能小。因此,xx取最大值bbyy取最小值cc。所以,我们直接输出bcb-c即可。

代码

#include <cstdio>
using namespace std;

int main()
{
	int a, b, c, d;
	scanf("%d%d%d%d", &a, &b, &c, &d);
	printf("%d\n", b - c);
	return 0;
}

B - Round Down

题目大意

给定一个数XX,求X\lfloor X\rfloor

0X101000\le X\le 10^{100}

输入格式

XX

输出格式

输出X\lfloor X\rfloor

样例

XX 输出
5.905.90 55
00 00
84939825309432908832902189.909230940980909132984939825309432908832902189.9092309409809091329 8493982530943290883290218984939825309432908832902189

分析

只需找到小数点并将其及后面的数位删去再输出即可。例如:5.905\sout{.90}

代码

#include <cstdio>
using namespace std;

int main()
{
	char c;
	while((c = getchar()) != '\n')
	{
		if(c == '.') return 0;
		putchar(c);
	}
	return 0;
}

C - Doubled

题目大意

11~NN之间有多少个数是另一个正整数重复两遍得来的?

1N<10121\le N<10^{12}

输入格式

NN

输出格式

输出答案。

样例

NN 输出
3333 33
13331333 1313
1000000010000000 999999

分析

这道题说白了就是要找到最大的XX,使得XX重复两遍不超过NN,并输出XX。我们可以使用二分法求出最大的XX
注意:这里的二分右边界最好设置为N\sqrt N,否则一不小心就会溢出!

代码

#include <cstdio>
#include <cmath>
using namespace std;

typedef long long LL;

inline bool check(const LL& x, const LL& n)
{
	LL p = 1LL;
	while(p <= x) p *= 10LL;
	return x * p + x <= n;
}

int main()
{
	LL n;
	scanf("%lld", &n);
	LL l = 0LL, r = sqrt(n);
	while(l < r)
	{
		LL mid = l + r + 1LL >> 1LL;
		if(check(mid, n)) l = mid;
		else r = mid - 1;
	}
	printf("%lld\n", l);
	return 0;
}

D - Hanjo

题目大意

有一个H×WH\times W的地板,请你在地板上铺砖。
有两种地砖:aabbaa地砖有AA个,是2×12\times1的可旋转长方形。bb地砖有BB个,是1×11\times1的正方形。问要将这个地板正好铺满,总共有多少种铺法?

1H,W,HW161\le H,W,HW\le 16
0A,B0\le A,B
2A+B=HW2A+B=HW

输入格式

H W A BH~W~A~B

输出格式

输出答案。

样例

HH WW AA BB 输出
22 22 11 22 44
33 33 44 11 1818
44 44 88 00 3636

分析

由于数据范围较小,我们可以用暴力搜索解决这道题。注意,这里搜索时为了避免重复计算,我们每次递归只尝试一个位置,这样还能有效加速。具体请看代码。

代码

#include <cstdio>
#define maxn 20
using namespace std;

bool mat[maxn][maxn];
int h, w, a, b, ans;

inline bool valid(int x, int y)
{
	return !mat[x][y] && x >= 0 && x < h && y >= 0 && y < w;
}

void dfs(int i, int j, int usedA, int usedB)
{
	if((usedA << 1) + usedB == h * w)
	{
		ans ++;
		return;
	}
	if(i == h) return;
	int ni, nj;
	if(j == w - 1) ni = i + 1, nj = 0;
	else ni = i, nj = j + 1;
	if(mat[i][j])
	{
		dfs(ni, nj, usedA, usedB);
		return;
	}
	mat[i][j] = true;
	// Rectangle (A)
	if(usedA < a)
	{
		if(valid(i, j + 1))
		{
			mat[i][j + 1] = true;
			dfs(ni, nj, usedA + 1, usedB);
			mat[i][j + 1] = false;
		}
		if(valid(i + 1, j))
		{
			mat[i + 1][j] = true;
			dfs(ni, nj, usedA + 1, usedB);
			mat[i + 1][j] = false;
		}
	}
	// Square (B)
	if(usedB < b) dfs(ni, nj, usedA, usedB + 1);
	mat[i][j] = false;
}

int main()
{
	scanf("%d%d%d%d", &h, &w, &a, &b);
	dfs(0, 0, 0, 0);
	printf("%d\n", ans);
	return 0;
}

E - Filters

题目大意

给定三个整数序列A=(a1,a2,,aN)A = (a_1, a_2, \dots, a_N)T=(t1,t2,,tN)T = (t_1, t_2, \dots, t_N)X=(x1,x2,,xQ)X = (x_1, x_2, \dots, x_Q)
我们如下定义NN个函数f1(x),f2(x),,fN(x)f_1(x), f_2(x), \dots, f_N(x)
fi(x)={x+ai(ti=1)max(x,ai)(ti=2)min(x,ai)(ti=3)f_i(x) = \begin{cases} x + a_i & (t_i = 1)\\ \max(x, a_i) & (t_i = 2)\\ \min(x, a_i) & (t_i = 3)\\ \end{cases}
对于每个i=1,2,,Qi = 1, 2, \dots, Q,求fN(f2(f1(xi)))f_N( \dots f_2(f_1(x_i)) \dots )

1N,Q2×1051 \le N,Q \le 2 \times 10^5
ai,xi109|a_i|,|x_i|\le 10^9
1ti31 \le t_i \le 3

输入格式

NN
a1 t1a_1~t_1
a2 t2a_2~t_2
\vdots
aN tNa_N~t_N
QQ
x1 x2 xqx_1~x_2~\dotsx x_q

输出格式

输出QQ行。第ii行应该包含fN(f2(f1(xi)))f_N( \dots f_2(f_1(x_i)) \dots )

样例

样例输入

3
-10 2
10 1
10 3
5
-15 -10 -5 0 5

样例输出

0
0
5
10
10

在这里,f1(x)=max(x,10),f2(x)=x+10,f3(x)=min(x,10)f_1(x) = \max(x, -10), f_2(x) = x + 10, f_3(x) = \min(x, 10),则有:

  • f3(f2(f1(15)))=0f_3(f_2(f_1(-15))) = 0
  • f3(f2(f1(10)))=0f_3(f_2(f_1(-10))) = 0
  • f3(f2(f1(5)))=5f_3(f_2(f_1(-5))) = 5
  • f3(f2(f1(0)))=10f_3(f_2(f_1(0))) = 10
  • f3(f2(f1(5)))=10f_3(f_2(f_1(5))) = 10

分析

(参考AtCoder官方题解
很容易想到,我们可以直接照做,即分别计算每个fN(f2(f1(xi)))f_N( \dots f_2(f_1(x_i)) \dots )。但是,这样做的时间复杂度是O(NQ)\mathcal O(NQ),所以肯定会TLE
我们考虑它们的复合函数F(x)=fN(f2(f1(xi)))F(x)=f_N( \dots f_2(f_1(x_i)) \dots )在图上怎么表示。

  • ti=1t_i=1fif_i是将图整体平移的操作;
  • ti=2t_i=2fif_i是将图的最小值设为aia_i
  • ti=3t_i=3fif_i是将图的最大值设为aia_i

所以,我们可以得到下图:
F(x)和x的关系

或者说,存在三个数a,b,ca,b,c使得F(x)=min(c,max(b,x+a))F(x)=\min(c,\max(b,x+a))
关于a,b,ca,b,c的具体计算请看代码。

代码

注意:这里的代码中的\inftyINF)一定不能直接设为long long的最大值,否则会溢出!

#include <cstdio>
#include <algorithm>
#include <climits>
using namespace std;

typedef long long LL;
const LL INF = LLONG_MAX >> 1LL;

int main()
{
	LL l = -INF, r = INF, add = 0LL;
	int n, q;
	scanf("%d", &n);
	while(n--)
	{
		LL a, t;
		scanf("%lld%lld", &a, &t);
		if(t == 1) l += a, r += a, add += a;
		else if(t == 2) l = max(l, a), r = max(r, a);
		else l = min(l, a), r = min(r, a);
	}
	scanf("%d", &q);
	while(q--)
	{
		LL x;
		scanf("%lld", &x);
		printf("%lld\n", clamp(x + add, l, r));
	}
	return 0;
}