GoodCoder666的个人博客

AtCoder Beginner Contest 187 A~D 题解

2021-01-03 · 9 min read
C++ 算法竞赛

A - Large Digits

题目大意

给定两个三位整数AABB,求它们数位和的最大值。
数位和:例如,123123的数位和是1+2+3=61+2+3=6

100A,B999100\le A,B\le 999

输入格式

A  BA~~B

输出格式

一行,即AABB数位和的最大值。

样例

输入 输出
123 234 9
593 953 17
100 999 27

分析

直接按题目照做即可。

代码

#include <cstdio>
#include <algorithm>
using namespace std;

int main(int argc, char** argv)
{
	char a[10], b[10];
	scanf("%s%s", a, b);
	int as = 0, bs = 0;
	for(int i=0; a[i]; i++)
		as += a[i] - '0';
	for(int i=0; b[i]; i++)
		bs += b[i] - '0';
	printf("%d\n", max(as, bs));
	return 0;
}

B - Gentle Pairs

题目大意

NN个点,每个点的坐标是(xi,yi)(x_i,y_i)xx坐标互不相同。
有多少对符合“11-1\le斜率\le1”的点?

1N1031\le N\le 10^3
xi,yi103|x_i|,|y_i|\le 10^3
xixjx_i \ne x_j (i<ji < j)

输入格式

NN
x1 y1x_1~y_1
\vdots
xn ynx_n~y_n

输出格式

输出答案。

样例

样例输入1

3
0 0
1 2
2 1

样例输出1

2

有三个点(0,0)(0,0)(1,2)(1,2)(2,1)(2,1)

  • (0,0)(0,0)(1,2)(1,2),斜率为22
  • (0,0)(0,0)(2,1)(2,1),斜率为12\frac12
  • (1,2)(1,2)(2,1)(2,1),斜率为1-1

22对符合条件的点。

样例输入2

1
-691 273

样例输出2

0

只有11个点,无法组成对,输出00

样例输入3

10
-31 -35
8 -36
22 64
5 73
-14 8
18 -58
-41 -85
1 -88
-21 -85
-11 82

样例输出3

11

分析

(x1,y1)(x_1,y_1)(x2,y2)(x_2,y_2)的斜率是y1y2x1x2\frac{y_1-y_2}{x1-x2}
推理过程:

1y1y2x1x21-1 \le \frac{y_1-y_2}{x_1-x_2} \le 1

y1y2x1x21|\frac{y_1-y_2}{x_1-x_2}| \le 1

y1y2x1x21\frac{|y_1-y_2|}{|x_1-x_2|}\le 1

为了防止浮点数精度误差,我们继续:

y1y2x1x2|y_1-y_2|\le|x1-x2|

这时,就可以写代码了。

代码

枚举所有对点即可。

#include <cstdio>
#include <cmath>
#define maxn 1005
using namespace std;
 
int x[maxn], y[maxn];
 
inline bool slope_check(int x1, int y1, int x2, int y2)
{
	int dx = abs(x1 - x2), dy = abs(y1 - y2);
	return dy <= dx;
}
 
int main(int argc, char** argv)
{
	int n, cnt = 0;
	scanf("%d", &n);
	for(int i=0; i<n; i++)
		scanf("%d%d", x + i, y + i);
	for(int i=0; i<n-1; i++)
		for(int j=i+1; j<n; j++)
			if(slope_check(x[i], y[i], x[j], y[j]))
				cnt ++;
	printf("%d\n", cnt);
	return 0;
}

C - 1-SAT

题目大意

给你NN个字符串S1,S2,...,SNS_1,S_2,...,S_N。每个字符串都由小写字母组成,前面有至多11!
找到S1,S2,...,SNS_1,S_2,...,S_N中任意一个字符串,使SS中出现了“!+这个字符串”(没有引号)。如果没有符合条件的字符串,输出satisfiable

1N1051\le N\le 10^5
1Si101\le |S_i|\le 10

输入格式

NN
S1S_1
\vdots
SNS_N

输出格式

如果有符合条件的字符串,输出任意一个;
否则,输出satisfiable

样例

样例输入1

6
a
!a
b
!c
d
!d

样例输出1

a

S1S_1aS2S_2!a,所以S1S_1符合条件;
S5S_5dS6S_6!d,所以S5S_5也符合条件,输出d也会被判为正确。

样例输入2

10
red
red
red
!orange
yellow
!blue
cyan
!green
brown
!gray

样例输出2

satisfiable

没有符合条件的字符串。

分析

如果暴力去枚举两个字符串(如,a!a),需要两重循环,复杂度为O(N2)\mathcal O(N^2)(由于字符串太短可以忽略字符串比较),这里NN最大为10510^5,所以,枚举法不可用。
我们再考虑O(nlogn)\mathcal O(n\log n)
可以每次输入字符串时判断一下,如果它以!开头将它的!后面的内容放入set中,否则将整个字符串放入vector中。最后,循环遍历vectorO(n)\mathcal O(n)),每次在set中查找这个字符串(O(logn)\mathcal O(\log n))。总时间复杂度为O(nlogn)\mathcal O(n\log n)

代码

#include <iostream>
#include <set>
#include <string>
#include <vector>
using namespace std;

vector<string> v;
set<string> s;

int main(int argc, char** argv)
{
	ios::sync_with_stdio(false); cin.tie(0);
	int n;
	cin >> n;
	while(n--)
	{
		string x;
		cin >> x;
		if(x[0] == '!')
			s.insert(x.substr(1));
		else v.push_back(x);
	}
	for(int i=0; i<v.size(); i++)
		if(s.find(v[i]) != s.end())
		{
			cout << v[i] << endl;
			return 0;
		}
	cout << "satisfiable\n";
	return 0;
}

D - Choose Me

题目大意

题目大意略,请自行前往AtCoder查看。
数据范围:
1N1051\le N\le 10^5
1Ai,Bi1091\le A_i,B_i\le 10^9

输入格式

NN
A1 B1A_1~B_1
\vdots
AN BNA_N~B_N

输出格式

输出答案。

样例

样例输入1

4
2 1
2 2
5 1
1 3

样例输出1

1

Takahashi在第三个城市演讲后,AokiTakahashi将分别得到5566个投票。

样例输入2

5
2 1
2 1
2 1
2 1
2 1

样例输出2

3

在任意三个城市演讲后,AokiTakahashi将分别得到4499个投票。

样例输入3

1
273 691

样例输出3

1

分析

换句话说,我们的目的就是使得AokiTakahashi的票数差距逐渐减少。
最开始,票数的差距是Aoki票数的和,也就是i=1nAi\sum\limits_{i=1}^nA_i
每去第ii个城市,差距减少2Ai+Bi2A_i+B_i,因此,我们可以贪心地先前往差距减少多的城市。这一点可以用数组+排序setpriority_queue三种方法实现(我选择的是priority_queuesetpriority_queue更快一些)。

代码

注意:一定不能忘记使用long long!!!

#include <cstdio>
#include <queue>
using namespace std;

typedef long long LL;

priority_queue<LL> q;

int main(int argc, char** argv)
{
	int n;
	scanf("%d", &n);
	LL diff = 0;
	while(n--)
	{
		LL ao, ta;
		scanf("%lld%lld", &ao, &ta);
		diff += ao;
		q.push(ao + ao + ta);
	}
	int ans = 0;
	while(!q.empty())
	{
		ans ++;
		if((diff -= q.top()) < 0)
		{
			printf("%d\n", ans);
			return 0;
		}
		q.pop();
	}
	return 0;
}